Sitecore and ASP.NET AJAX 3.5

Tried to get ASP.NET AJAX to work, but as I copied my project into the web-dist, the default settings for it weren’t saved into the web.config.

Quick & dirty trick to enable it fast:

  1. Change your project build target from .NET 3.5 to .NET 2.0
  2. Update the reference list(remove unused or broken resources)
  3. Change the build target back to .NET 3.5

Et voila!

2 thoughts on “Sitecore and ASP.NET AJAX 3.5”

  1. I have not found much use from ASP.NET AJAX 3.5. I still use Anthem.NET, since no Web.config settings are required (you only have to add its DLL as a reference to your .NET solution); it’s easy to use; and less of a learning curve to employ (i.e. Anthem.NET webcontrols extend .NET webcontrols, thereby requiring less time searching through its API just to figure out what to do).

    Also, Anthem.NET can be used in .NET 1.1/2.0/3.0. Can’t say this for ASP.NET AJAX 3.5. Microsoft is a bit slow in enhancing its technologies versus others. Anthem.NET is light-years ahead of ASP.NET AJAX 3.5.

    Here’s where you can get Anthem.NET (it’s open source):

    http://anthemdotnet.com/

    Here are samples of Anthem.NET in action:

    http://anthem.talloaksoftware.com/

Comments are closed.